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Week 2 

Exercise 1(a) 

Aim 

• To understand the use of RTD  temperature sensor 

• To understand the use of Sub VI’s 

• To create a new sub VI 
 

To complete this exercise, you will need the IC temperature sensor available 

on the BNC-2120, SCB-68, or DAQ Signal Accessory.  

 

Front Panel 
1. Select File»New to open a new front panel. 

2. Create the thermometer indicator, as shown on the following front 

panel. 

 

 
 

a. Select the thermometer on the Controls»Numeric 

Indicators palette and place it on the front panel. 

b. Type Temperature inside the label and click outside the label 

or click the Enter button on the toolbar. 

c. Right-click the thermometer and select Visible 

Items»Digital Display from the shortcut menu to display 

the digital display for the thermometer. 

3. Create the vertical switch control. 

a. Select the vertical toggle switch on the Controls»Buttons 

palette. 

b. Type Temp Scale inside the label and click outside the label 

or click the Enter button. 



c. Use the Labeling tool to place a free label, deg C, next to the 

TRUE position of the switch, as shown in the previous front 

panel. 

d. Place a free label, deg F, next to the FALSE position of the 

switch. 

Block Diagram 

4. Select Window»Show Diagram to display the block diagram. 

5. Build the following block diagram. 

 
a. Place the DAQ Assistant Express VI located on the 

Functions»Input palette.  Make the following 

configurations in the DAQ Assistant configuration wizard. 

i. Select Analog Input as the measurement type. 

ii. Select Voltage. 

iii. Select ai0 as the channel from your data acquisition 

device. 

iv. In the Task Timing section, select Acquire 1 sample. 

 

b. Place the Convert from Dynamic Data function located on 

the Functions»Signal Manipulation and select Single 

Scalar as the Resulting data type. 

c. Place the multiply function located on the 

Functions»Numeric palette. This function multiplies the 

voltage that the AI Sample Channel VI returns by 100.0 to 

obtain the Celsius temperature. 

d. Select Functions»Select a VI, navigate to the Convert C to 

F VI, which you built in Exercise 2a, and place the VI on the 

block diagram. This VI converts the Celsius readings to 

Fahrenheit. 

e. Place the Select function located on the 

Functions»Comparison palette. This function returns either 

the Fahrenheit (FALSE) or Celsius (TRUE) temperature 

value, depending on the value of Temp Scale. 



f. Right-click the y terminal of the multiply function, select 

Create»Constant, type 100, and press the <Enter> key to 

create another numeric constant. 

g. Use the Positioning tool to place the icons as shown in the 

previous block diagram and use the Wiring tool to wire them 

together. 

Tip To identify terminals on the nodes, right-click the icon and select 

Visible Items»Terminal from the shortcut menu to display the connector 

pane. 

6. Display the front panel by clicking it or by selecting 

Window»Show Panel. 

7. Click the Continuous Run button, shown at left, to run the VI 

continuously. 

8. Put your finger on the temperature sensor and notice the 

temperature increase. 

9. Click the Continuous Run button again to stop the VI. 

10. Create the following icon, so you can use the Temperature VI as a 

subVI. 

 
a. Right-click the icon in the upper right corner of the front 

panel and select Edit Icon from the shortcut menu. The Icon 

Editor dialog box appears. 

b. Double-click the Select tool on the left side of the Icon 

Editor dialog box to select the default icon. 

c. Press the <Delete> key to remove the default icon. 

d. Double-click the Rectangle tool to redraw the border. 

e. Use the Pencil tool to draw an icon that represents the 

thermometer. 

f. Use the Foreground and Fill tools to color the thermometer 

red. 



Note To draw horizontal or vertical straight lines, press the <Shift> key 

while you use the Pencil tool to drag the cursor. 

g. Double-click the Text tool, shown at left, and change the 

font to Small Fonts. 

h. Select the B&W icon and select 256 Colors in the Copy 

from field to create a black and white icon, which 

LabVIEW uses for printing unless you have a color printer. 

i. When the icon is complete, click the OK button. The icon 

appears in the upper right corner of the front panel. 

11. Select File»Save to save the VI. Choose a location on your hard 

drive and save the VI as Thermometer.vi. 

12. Select File»Close to close the VI. 

 

 

End of Exercise  

 

Week 2 

Exercise 1(b) 

Aim  

• To understand the use of shift registers 

• To average the last three temperature measurements and display the 

same on the waveform graph. 

 

 

Front Panel 

1. Open the Temperature Monitor VI, which you built in Exercise 4-1. 

2. Select File»Save As and rename the VI Temperature Running 

Average.vi. 

 
Block Diagram 
3. Display the block diagram. 

4. Right-click the right or left border of the While Loop and select 

Add Shift Register from the shortcut menu to create a shift register. 

5. Right-click the left terminal of the shift registers and select Add Element 

from the shortcut menu to add an element to the shift register. 

6. Modify the block diagram as follows. 

 



 
 

a. Press the <Ctrl> key while you click the Thermometer VI and drag 

it outside the While Loop to create a copy of the subVI. 

(MacOS) Press the <Option> key. (Sun) Press the <Meta> key. (Linux) 

Press the <Alt> key. 

The Thermometer VI returns one temperature measurement from 

the temperature sensor and initializes the left shift registers before 

the loop starts. 

b. Place the Compound Arithmetic function located on the Functions» 

Numeric palette. This function returns the sum of the current 

temperature and the two previous temperature readings. Use the 

Positioning tool to resize the function to have three left terminals, 

shown at left. 

c. Place the Divide function located on the Functions»Numeric 

palette. This function returns the average of the last three 

temperature readings. 

d. Right-click the y terminal of the Divide function, select Create» 

Constant, type 3, and press the <Enter> key. 

e. Use the Labeling tool to double-click the numeric constant wired 

to the Wait until Next ms Multiple function, type 500, and press 

the <Enter> key. 

7. Save the VI because you will use this VI later in the course. 

8. Run the VI. 

During each iteration of the While Loop, the Thermometer VI takes 

one temperature measurement. The VI adds this value to the last two 

measurements stored in the left terminals of the shift register. The VI 

divides the result by three to find the average of the three measurements, 

the current measurement plus the previous two. The VI displays the 



average on the waveform chart. Notice that the VI initializes the shift 

register with a temperature measurement. 

9. Place the Bundle function located on the Functions»Cluster palette to 

display both the average and the current temperature measurement on 

the same waveform chart. This function bundles the average and current 

temperature for plotting on the waveform chart. 

10. Save and run the VI. The VI displays two plots on the waveform chart. 

The plots are overlaid. That is, they share the same vertical scale. 

 

 

Week 2 

Exercise 2 

Filtered and unfiltered signal 

Note: Unlike week 1 step by step procedure is not given. Students are 

encouraged to draw the block diagram on their own using a few tips 

mentioned below. In case of any doubts, call your instructor for help. 

 

Aim 

• To understand the use of filtering a signal 

• Learn to save data 

• To understand the use of formula node 

• To measure the peak to peak amplitude at various intervals 

• To understand the operation of a warning signal. 

 

Procedure 

Front Panel 

1. The front panel appears as follows. 

 



 
 

 

2. To display the filtered and the unfiltered signal we require having two 

waveform graphs. 

3. To display the peak to peak amplitude, it is necessary to have one numeric 

indicator. 

4. To display the warning. A round Led is being used. Right click on the 

front panel>Boolean>Round Led. Resize the Led using positioning tool. 

5. In order to save data only at regular intervals of time, it is necessary to 

introduce a button, so that whenever the button is pressed the data gets 

saved. Right click on the front panel>Boolean>Push Button. Rename the 

button as Write to file. Right click on the button>Mechanical 

action>select latch when pressed action. 

 

Block Diagram 



 
5. The first step in building the block diagram is to stimulate a signal. Right 

click on the block diagram>Express>Input>Simulate signal. In the 

property box accept all defaults. 

6. Since the above stimulated signal has no noise, it is essential to introduce 

noise to understand the concept of filtering. Right click on the block 

diagram> Express>Input>Stimulate Signal. In the property box check 

mark on “Add Noise” and select uniform white noise from the pull down 

menu. Ensure that the Noise amplitude is 0.1 and seed number is -1. Check 

mark signal name and enter 60Hz and Noise. 

7. To merge the two signals we use the formula node. Right click on the 

block diagram>Express>Arith and compare>Formula. In the property 

box under label in place of X1 enter Sine and in place of X2 enter 60 HZ 

and Noise. Add the two elements. Click X1+X2 

8. Next step is to filter the signal. Right click on the block 

diagram>Express>Signal Analysis>Filter. In the property box under 

filtering type select High pass and accept all other defaults. 

9. The next step is to measure the peak to peak amplitude. Right click on 

the block diagram>Express>Signal Analysis>Amp and level. In the 

property box click Peak to Peak. 

10. The next step is to introduce the warning signal when the peak to peak 

amplitude crosses a cut off value. Right click on the Block 

diagram>Comparison>comparison. Under compare condition check mark 

Greater and under comparison inputs check mark value and enter 2. 

11. The next step is to save the data to a file. Right click on the block 

diagram>Express>output>Write measurement file. In the property box 



under action check Ask user to choose file and ask each iteration. Accept 

all other defaults. 

12 In order to repeat the process introduce a While loop.  

13 You can also introduce a Time delay function. With a delay of 0.2 

seconds. 

 

 

Wiring 

• Wire the two stimulated signals to the formula node. 

• Results from the formula node to Signal. It’s also necessary to Wire 

the results from the formula node to Unfiltered Signal Graph 

• Filtered signal to Amplitude and Level measurements and also to 

filtered signal graph. 

• Output of peak to peak amplitude to the Peak to Peak Indicator, also 

to Comparator, also to write measurement file. 

• Connect the write to file button to write measurement file. 

• Connect the result of the comparator to the warning LED. 

 

Save the program 

Run the program and verify if the signal is filtered. 

 

 

 

Test (Compulsory) 

After you have completed the exercise, replace the simulate signal with 

the DAQ board Signal and analyze the results. 

 

End of Exercise 

Week 2 

Exercise 2 

Digital I/O 

Aim 

• To understand the concept of arrays 

• To control the digital I/O lines on the DAQ device 

• To ensure that the LED’s on the front panel and the DAQ device match. 

 

Procedure 

Front panel 

The front panel appears as follows: 



 
 

1. In order to incorporate LED’s within an array the following procedure 

must be followed. Right click on the front panel>Array>Array.   

2. Right click on the front panel>Boolean>Round LED. Place the LED 

inside the array. Using the positioning tool stretch the array in 

horizontal direction (towards right) until four LED’s appear on the 

front panel. Number 4 is chosen because the number of LED’s on the DAQ 

board is 4. 

 

Block diagram 

Note: Components needed to build this program has been summarized 

below. Students are encouraged to build the block diagram on their 

own. Call your instructor in case of any queries. 

3. Right click on the block diagram>Array>Array subset. Since there are  

 4 LED’s the length of the subset needs to be 4. Create a constant and assign 

a value 4. 

4. In order to reverse the order of the elements. Right click on the block 

diagram>Array>Reverse 1D array. 

5. Next step is to convert the Boolean array to Numbers. Right click on the 

block diagram>Boolean>Array to Number. 

6. The next step is to build the array. Right click on the Block diagram> 

Array>Build array. 



7. To activate the LED’s on the DAQ board, the DAQ assistant needs to be 

incorporated. (Configure the DAQ assistant on the block diagram on your 

own) 

8. A while loop may be needed for smooth operation. 

9. Save the VI 

10 Run the VI. 

 

Test (Compulsory) 

Do you think a logic gate is required for better operation? 

Try incorporating a logic gate? (Ask your instructor whether the logic 

gate selected by you is right or wrong?) 

What would be the connections to this logic gate?  

 

End of the Exercise 

 

 


