Overview
This user's guide demonstrates how to monitor and approve student employee time and run the Student Time Approval Report.

Supervisors/Approvers must approve student assistant time monthly. Each student assistant should enter time daily, after each shift. Once time entry is complete for the month, a process is run to make the time available for approval. Managers are notified when the process is complete and can follow the steps outlined in this guide to approve the time for their student assistant employees.

If you are responsible for a small number of students, use the Time and Labor Launch Pad to monitor student time entry throughout the month. If you have a large number of students, use the Public Query to verify and review time entry. See the appropriate section for details.

Table of Contents
Monitor and View Student Time Using the Time and Labor Launch Pad................................................................. 2
Monitor and View Student Time by Running the Public Query.................................................................................. 7
Approving Student Time........................................................................................................................................... 11
Generating the Student Time Approval Report....................................................................................................... 15
Monitor and View Student Time Using the Time and Labor Launch Pad
This section demonstrates how to monitor time using the Time and Labor Launch Pad. The Time and Labor Launch Pad allows you to monitor monthly time entry for your student assistants and view payable time by month.

To login to MySJSU
1. Navigate to MySJSU (http://my.sjsu.edu/).
2. Click MySJSU SIGN IN.

The ORACLE PEOPLESOFT Enterprise login page displays.
3. Enter your SJSU ID and Password.
4. Click the Sign In button.

Note: If you have difficulty logging in, contact the CMS Help Desk by email (cmshelp@sjsu.edu) with your full name, SJSU ID, date of birth and/or address for verification.
5. From the **Main Menu**, navigate to **Self Service > Manager Self Service**

The **Main Menu** displays.

6. Continue the navigation **Time Management > View Time > Time and Labor Launch Pad**
The Time and Labor Launch Pad Select Employee page displays.

7. Enter search criteria, such as Empl ID and Empl Rcd Nbr.
   
   Note: If you are familiar with the Job Codes, you can also search by Department and Job Codes to view groups of students in the results (examples of Job Codes include 1870 for Student Assistant, 1871 for Work Study, 1868 for NRAT, and 1150 & 1151 for Instructional Student Assistant).

8. Click the Get Employees button.

9. Click to select employee by name.
The Time and Labor Launch Pad displays.

10. Verify student Job Title.

11. To change the time period, use the dropdown menus, and then click the View button.
   - **Reported Hours**: Time entered.
   - **Payable Hours**: Time approved.

12. Click the underlined dates to view more information about the time (see following screenshot).

13. View the legend at the bottom to identify the values in the calendar.

A Date Details box (expanded from the prior screenshot) displays.

14. Click the underlined date.
**The Details page corresponding to a specific date displays.**

- **Reported Elapsed Time:** Displays student time.
- **Exceptions:** Displays messages about time entry that was outside the rules. Example: **Student Exceed 20** means that a student worked more than the 20 hours per week limit.
- **Payable Time:** Displays information about the hours.

### Field Description List: Status Terms

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>[blank]</td>
<td>Time is not approvable</td>
</tr>
<tr>
<td>Needs Approval</td>
<td>Time is ready to be approved</td>
</tr>
<tr>
<td>Approved</td>
<td>Time has been approved.</td>
</tr>
<tr>
<td>Transmitted</td>
<td>Sent to PIP. Information has been sent to the State Controller’s Office for processing</td>
</tr>
</tbody>
</table>
Monitor and View Student Time by Running the Public Query

This section demonstrates how to monitor and view time using the Public Query. Managers should review time throughout the month to make sure students are entering time accurately. After the pay period has ended, a student cannot modify reported time.

The Main Menu displays.

1. From the Main Menu, navigate to Reporting Tools > Query.
2. Click Query Viewer.

The Search By Query Name page displays.

3. Enter the partial name of the query SJ_SELF.
   
   Note: The full query name is SJ_SELF_SERVICE_TIME_REPORTED.

4. Click the Search button.

   Note: You can add this query as a Favorite and subsequently select Favorite to run the query.

5. Click the Favorite link.
The My Favorite Queries row appears.

Note: It will now display when you navigate here.

6. To run the query, click the HTML link.

The Self Service Time Entry Query page displays.

7. Enter the DeptID.

8. Enter the Begin Report Date for the first day to view time.

9. Enter End Report Date for the last day to view time.

10. Click the View Results button.
The time entry information displays.

11. Review the student time entry.

Note: You can use this query to view time on an SJSU holiday by entering the date criteria. If the student entered time inadvertently, you can either the student to remove the time or you can not approve the time.

Field Description List: Self Service Time Entry Query Page (above)

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Student name.</td>
</tr>
<tr>
<td>ID</td>
<td>Student employee ID number.</td>
</tr>
<tr>
<td>Empl Rcd#</td>
<td>Student record number.</td>
</tr>
<tr>
<td>Rpt Dt</td>
<td>Date of the reported hours.</td>
</tr>
<tr>
<td>Quantity</td>
<td>Number of hours reported.</td>
</tr>
<tr>
<td>TRC</td>
<td>Time Reporting Code.</td>
</tr>
<tr>
<td>DeptID</td>
<td>Department ID number.</td>
</tr>
<tr>
<td>User</td>
<td>Student employee User ID.</td>
</tr>
<tr>
<td>Job code</td>
<td>Tied to the position, such as student assistant (1870) or work study student assistant (1871).</td>
</tr>
<tr>
<td>Position</td>
<td>Tied to their Job Data. It is the student employee’s position number.</td>
</tr>
<tr>
<td>Title</td>
<td>Student employee job title.</td>
</tr>
</tbody>
</table>
Note: You can move the data into an Excel spreadsheet.

12. Click Excel Spreadsheet.

The data displays in an Excel spreadsheet.

Note: You can now sort the information and view the students you are responsible for.
Approving Student Time

This section demonstrates how to approve student time. Perform this process on the first day of the new month to approve student time entered in the previous month. For example, student time entered during the month of November will be approved on the first day of December.

The Main Menu displays.

1. Navigate to Manager Self Service > Time Management > Approve Time and Exceptions.

2. Click Payable Time.

The Approve Time for Time Reporters page displays.

3. Enter criteria to search for your student assistants:
   - EmplID: Enter an employee ID if you approve by employee. Then enter the employee record number in the field below it.
   - Department: Enter the Department number.

Note: You can search by any of criteria shown.
4. After you enter your search criteria, enter the following:
   - **Start Date**: Enter the first date of the pay period.
   - **End Date**: Enter the last date of the pay period.

5. Click the **Get Employees** button.

   *Note: Not all pay periods end on the last day of the month. Please refer to the Master Payroll Calendar on the Calendars page of the HR website: [http://www.sjsu.edu/hr/calendar_news/calendar/](http://www.sjsu.edu/hr/calendar_news/calendar/)*

   - *The student employees and their total hours display.*

6. Approve time one of two ways:
   - **Check the box next to the student’s name.**
   - **Or**
   - Click the student’s name, which displays the hours entered for each day in the pay period.
7. Before approving time, always verify the following:
   - Student Name
   - Empl Rcd Nbr
   - Job Description
   - Total Payable Hours

8. Click the Student Name to view the daily hours for that student.

---

**The Approve Payable Time page displays with each day listed and the number of hours worked.**

9. Select the hours to approve by checking the Select box.

10. Click the Approve button.

   Notes: If there is time you do not approve, ensure the box is not checked before clicking the Approve button.

   Do not approve hours if you see something wrong or if time is missing.
A warning message displays, confirming your intent to approve.

11. Click OK.

Note: Approved time cannot be unapproved. If you have any questions, do not approve the time. Contact the CMS Help Desk at 408-924-1530, or contact Payroll.

The Save Confirmation message displays.

12. Click OK.

The Approve Payable Time page displays.

Note: The time approved will no longer show and is now being transmitted to the State Controller’s Office.

Once time is approved, a Student Time Approval (timesheet) report is generated for your students. After all time has been approved, one person in the department will print it and send it to Payroll. To generate the Student Time Approval report, continue to the next section.
Generating the Student Time Approval Report

This section demonstrates how to generate the Student Time Approval Report. This report is required by the Payroll department after all time is approved. Typically, the administrator for the whole department will generate and print the report by department ID and then send the signed document to the Payroll Office. The report can be run by department number or employee ID. An approver can also run the report for selected student assistants by entering their employee IDs.

**The Main Menu displays.**

1. From the **Main Menu**, navigate to **SJSU Human Resources > Time and Labor**.

2. Click **Student Time Approval Report**.

**The Student Time Approval search page displays.**

3. If it is your first time running this job, click the **Add a New Value** tab to create a new run control.

   *Note: Once the run control ID exists, you can click the Search button on this page and use it going forward.*

   **The Student Time Approval page displays.**

4. Enter a **Run Control ID** for this process of no more than 30 characters and no spaces.

   *Example: RUN_TIMESHEET.*

5. Click the **Add** button.
The Student Aprvl Rpt page displays.

6. Enter the Pay Period End Date.

7. Enter Emplid(s) if you would like to see only specific students on your report. Or

8. Enter the Department(s) ID to run a report for the departments.

9. Click the Add [+] icon to add rows for more employee IDs or department IDs.
A new blank row displays.

10. Enter an **Emplid**.

   Note: If you do not know the employee ID, click the **Lookup** (magnifying glass) icon to search for the student by name.

11. Continue adding employee IDs as needed.

A completed page displays.

12. Click the **Run** button.
The Process Scheduler Request page displays.

13. **Server Name:** Select PSUNX from the dropdown menu.

14. Select **Web** from the **Type** dropdown menu and **PDF** from the **Format** dropdown menu.

15. Click **OK**.

**Student Approval Report page displays.**

*Note:* A Process Instance number appears, indicating that your report is running.

16. Click **Process Monitor**.

The Process List displays.

17. Wait at least 15 seconds, and then click the **Refresh** button.

18. Continue waiting and then clicking the **Refresh** button until **Run Status** changes to **Success** and **Distribution Status** changes to **Posted**.

19. Click **Details**.
The Process Detail page displays.

20. Click View Log/Trace to view and print the report.

The View Log/Trace Report displays.

21. Click the link with the .PDF extension.
The report displays.

22. Print the report from Adobe Acrobat or your browser.

Notes: Depending on how many students are in your department, multiple pages may print.

Employee IDs, Record Numbers and Names that appear on the report have been redacted here to protect privacy.

Field Description List: Process Detail Page (above)

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>EmplID</td>
<td>Student employee ID.</td>
</tr>
<tr>
<td>RCD</td>
<td>Student record number.</td>
</tr>
<tr>
<td>Name</td>
<td>Student name.</td>
</tr>
<tr>
<td>Deptid</td>
<td>Department ID.</td>
</tr>
<tr>
<td>Job Cd</td>
<td>Job code. Tied to the position, such as student assistant (1870) or work study student assistant (1871).</td>
</tr>
<tr>
<td>Unit</td>
<td>Value used to sort paychecks and other documents.</td>
</tr>
<tr>
<td>Hrly Rt</td>
<td>Amount the student is paid per hour.</td>
</tr>
<tr>
<td>Appvd Hrs</td>
<td>Approved hours.</td>
</tr>
<tr>
<td>Est. Gross</td>
<td>Estimated gross amount the student will be paid for the hours reported.</td>
</tr>
<tr>
<td>Status</td>
<td>Approved or Transmitted will display.</td>
</tr>
<tr>
<td>Approved</td>
<td>Hours have been approved by the Approver.</td>
</tr>
<tr>
<td>Transmitted</td>
<td>Hours Approved and sent to the State Controller's office to be processed for payment.</td>
</tr>
</tbody>
</table>
Note: The status of the students on the report may appear as either Approved or Transmitted. Both terms are acceptable.

Once the report is printed, the designated person in the department signs it and then submits it to the Payroll Office. Check with your department to find out who is responsible for handling the report for your office. You are allowed t