SJSU Component Use Notes
Faculty Profiles
1) Staff Listing formatting example
· Tables are not used for formatting. Each staff listing is contained in a <p> with <p style="clear: left;"> applied.
· Image uploaded at suggested at  200 w x 267 h. Image uploaded can be variable as long as it is portrait. The style applied to image sets width at 170px for all)
· Style applied to the image:
width: 170px; float: left; margin: 0 1rem 2rem 0;
· Placeholder image is attached for staff without a photo.

[image: https://lh4.googleusercontent.com/5XpBHYdgskcB5XuG2xkjTWfdgiVe0ILSh3tSeFVXsAKQ8pzG12aZPoFSSv1K-FJOMkZfn5Y_ii8uM6iSJyMXgxkuO4S7lca7e4HGwgWa-B365xrG1WSqJ3PWvgKPoVbIxqjzIpUT]
2) Bio page formatting example
· Image uploaded at dimensions 600 w x 800 h (pixels). Image is responsive.
· Style applied to the image:
width: 250px; float: left; margin-right: 18px; margin-bottom: 18px;



Accessibility Issues
<a> title attribute
Example: http://newdev.sjsu.edu/cfd/teaching-learning/anti-racist-pedagogy.php
Use of the title attribute is not necessary and can reduce usability for assistive tech users.
Component Design vs Use Issues
Call to action
Use CTAs sparingly for transactional purposes. 

Review the help text in the CMS when adding components to see additional standard recommendations (also visible on the Card Component at https://www.sjsu.edu/migration/showcase/landing-page-sample.php )

CTA Use Cases/Examples:
· Good use of CTA buttons in a card component: https://www.sjsu.edu/communications/help/index.php
· Use of linked headlines in the card component: https://www.sjsu.edu/admissions/graduate/index.php
· Icons with a card component where headline looks like a CTA button: https://www.sjsu.edu/healthadvisories/sjsu-adapt/index.php
· Icons with a card component: https://www.sjsu.edu/campusmasterplan/   
· Mixed use of headlines and CTAs in card component: https://www.sjsu.edu/bursar/index.php
· Use of CTAs with other components: https://www.sjsu.edu/strategicplan/
Calendar Component
Example: http://newdev.sjsu.edu/bursar/
All of the text embedded in a calendar event item is wrapped in an <a> element. That means that the visible text of a calendar event becomes the descriptive link text. That link text must follow standard accessibility compliance rules and recommendations.

The design is made to link to the campus events calendar or a subpage on the site where there is an event listed.

The fields of a calendar event are explicitly designed to contain:
· Month
· Day
· Time
· Title
· Location

Inserting additional text that does not match those categories applies a clock or location icon to unrelated content.
Content Migration Process


· IA Approval.  IA Team has completed the final sitemap. Migration tracker is created. 


· Autoscript Migration. Dev Team runs OU Campus migration script.


· Update Doc and Image Folders. 


· Site Permissions Set. 


· Site Structure Updated. Migration Team will move or build out pages in the CMS as indicated by the approved sitemap. Pages that have been removed from the sitemap will go to the recycle bin. 


· Update Page Properties. Migration Team will update page title, meta description and navigation order under Page Properties tab in OU Campus.


· Update Page Content Formatting. This includes updating formatting, links, tables, images and accordions. 


· Migrate New Content. New pages for the site will be created in Gather Content. Once they have been approved we will manually migrate the content to OU Campus. 


· Content Strategy Review. Content Strategy Team will review and update pages that were consolidated and edit content in OU Campus. 


· QA New Dev. Run SortSite on the NewDev environment. Verify all content issues have been resolved. 


· Beta Review. Site owners will review and finalize their site after QA is complete. 
Steps 
Once you are logged into OU Campus. Select the “NewDev” site from the dropdown menu in the top right corner. Folders and pages are listed alphabetically in OU Campus. All sites should have their own folder within the NewDev environment. 


1. Manage Pages

Before you start migration, review the Information Architecture Tab and Migration Tracker Tab in the Master sheet. 

Recycle Pages
Recycle pages that have been removed from the site IA. It might be easier to work on this in the Audit (MasterSheet) tab. Pages that have been removed from the site architecture are labeled with a - dash in column E “Slickplan Mapping”. Note: If you need to delete an entire section, go into the folder and recycle all pages first. Then you can delete the folder. OU will give a warning about this but if the pages are deleted with the folder they cannot be retrieved. 

Restructure the Site
Create or edit the folders for new parent pages. Move the page to the new placements based on approved IA. 

Create blank pages for any page labeled as “New Content”. Select New and then “New Content Page” for pages that have no old URL and are labeled as New Content. 

Edit folder URL title by going to file > rename and updating the title of the folder.

There is a file within each folder called _props.pcf that will need to be updated as well. To edit this click into the folder section and click into the _props.pcf. Update the Section Title under the Page Parameters on the Properties tab. 

Update URL Title
Make sure that URL titles use best practices. Ideally, titles should be one word, concise as possible, all words be lowercase, use dashes to separate words (not underscores or spaces). Update pages that do not follow best practices. 

More information on how to manage pages in OU Campus

After this step is complete label the page status as “Manage” in the Migration Tracker. 

2. Page Properties
Click on the Light Bulb Icon [image: https://lh3.googleusercontent.com/EPll4Qes0ArOXBwiqH-4l1DrJbNgQUqISoGEAlJj1h6WCR16DWDPaIDSMIzv92-Lo94hBe74_WcAYMg-gn5OAn2NpKtUZ1uYOivQk0kUhYXkSr7t0qdCngpbfNweBsG-S5WwK1CP]Click on the Properties tab of the page you want to edit. Once you are checked-in you will be able to see the Page Parameters. It does not appear unless you have the page locked/checked out with the light bulb icon. 

Update Page Titles
For the majority of pages this will remain the same. There may be slight changes, like changing “&” to “and” to better align with SJSU’s editorial guidelines. Update both Page title fields under Title and Metadata and Page Content. Update the Breadcrumb field with the same title. Make sure these match the updated/approved sitemap listed in the migration tracker. 

Update Meta Description
If the page has no meta description, uses a duplicate of the Page title or Meta Keywords be sure to update by pulling the first sentence from the page that makes sense. If the page is a link-farm with no content to pull use a generic description like:

Understand the steps involved in ...
[bookmark: _GoBack]Find information on the Committees involved in the …
Find important information on the policies ...

Update Navigation Order
Order pages to match the sitemap. Page navigation is weighted so in order for a page to appear first add 10 to the Navigation Order field, the next page 20, then 30 and so on by 10s. 

Update Friendly Title field. Navigation Config - Admin section is left blank. 

More information on the editing the page parameters in OU Campus

After this step is complete label the page status as “Properties” in the Migration Tracker. 


3. Update Page Content / Formatting

Links to Files 
Link to files will need to be recreated. The old URL page should still be there and the filenames will be the same. To link the files, click on the link and then select the link icon. The old link information will appear in the pop-up window. Copy the file name and temporarily add it to the Title field. Then navigate to the docs folder and select the file name that matches. Update the link and Title fields. 

Links to Pages
Linking to WWW folders or site. Do not link to other sites within the NewDev environment. 

More information on inserting links in OU Campus

Consolidating Pages
These will be listed as duplicated rows in the content tracker so we can keep track of the plan for each page. 

Consolidated pages will be labeled as a,b,c to indicate the ordering placement on the page. The IA team has identified 3 types of consolidation:


1. Pages will be fine combined as-is. The content can be combined together based on the slickplan mapping and will still make sense.
2. Pages have some content that is identical and some that is unique. I’ve tried to account for these pages by leaving notes of what to add/pull/delete from certain pages in the notes column. 
3. Pages need lots of editing help (e.g., new headers, intro, possibly reorganized, etc.). For these pages we will add them based on the slickplan mapping and then alert the Content Strategy Team (Sarah Schwartz) to review and make changes as needed. 

Once the page content has been combined. The duplicate pages can be moved to the recycle bin. Move the row in the Migration Tracker down to the “recycle bin” section. 

Heading Styles
Make sure heading styles for content flow in the correct order. Fix any content that uses bold or other formatting styles.

If Heading content is linked as a call to action, if possible, move linked text to the content instead of the heading. 

Images 
Images should support the content on the page. Remove any images that are stock photography or bad quality images that are not relevant/support the content on the page. All image assets should live within the sites pics folder. 

Information about Images on OU Campus

Formatting 
Check the source, clean is needed. Fix any common formatting errors. Many formatting errors have been identified in the qualitative audit.

Information on OU Campus Toolbar 

Tables
Is the table used for information, or formatting) If the table is used for formatting pull content out. 

There is a snippet of a formatted table that can be placed within the page content. 

More information about editing tables in OU campus

Accordions
Accordions are a new component. If the page can benefit from the use of an accordion add one. Keep the accordions tabs under 20. 

To add an accordion Widgets > Snippets and drag and drop that element into the page. These can be edited/moved in the Source code if needed. 

Generally, accordions should always be the last element on the page. Unless there is legal text related to the accordion content.

For consistency, keep all FAQs in accordions. 

Note: Accordions can’t handle much other than plain content. Avoid tables, ordered/unordered lists and advanced formatting.

Update HTML Characters
An example of on page content characters that do not translate during the migration script are:
&gt; - Update to >
&lt;  - Update to <

Editorial Guidelines 
(Many of these may be listed in the master sheet under the Qualitative Notes Column. Update phone numbers, using and instead of & )
https://www.sjsu.edu/communications/docs/sjsu_powersource.pdf

After these steps are completed, change the migration status to “Format”  in the Migration Tracker. 

4. QA Site 

OU Check 
Once you have updated the page, run the OU page check. 

https://support.omniupdate.com/learn-ou-campus/pages-files/review/page-check.html 

Sort Site in NewDev

After completing the migration for the site, run SortSite for the NewDev site. Be sure to uncheck the robots option under Options > Blocks so the scan can run on the NewDev environment. 

This scan will happen after new content from Gather Content has been migrated over. 

Open SortSite and go to the newdev site. 

Go to View > Options > Blocks

Under Blocked Links add the following:

http://newdev.sjsu.edu/visit/index.php
http://newdev.sjsu.edu/visit/silicon-valley.php
http://newdev.sjsu.edu/academics/index.php
http://newdev.sjsu.edu/academics/colleges-and-departments.php
http://newdev.sjsu.edu/academics/centers.php
http://newdev.sjsu.edu/tuition-and-fees/index.php
http://newdev.sjsu.edu/housing/index.php
http://newdev.sjsu.edu/campus-life/health-and-wellness.php
http://newdev.sjsu.edu/campus-life/safety.php
http://newdev.sjsu.edu/campus-life/events.php
http://newdev.sjsu.edu/campus-life/traditions.php
http://newdev.sjsu.edu/campus-life/sac.php
http://newdev.sjsu.edu/about/index.php
http://newdev.sjsu.edu/about/partnerships.php
http://newdev.sjsu.edu/about/history/index.php
http://newdev.sjsu.edu/about/doing-business-with-sjsu.php
https://sjsu.instructure.com/

Make sure the Obey robots.txt box is unchecked. Hit okay and save. 

Go to Check > Choose Rules > Accessibility and make sure the following settings are correct:


· WCAG 2.1 AA


· Section 508 Refresh (2017)



Run the scan for Check > Folder and let the scan run. If it seems to take hours to run, it may be trying to crawl the entire site. If so, cancel and try again. 

Once the scan is complete go to File > Export and Save as the CSV for the Issue Report. 

Copy/paste the scan into the Site’s Master Sheet under the ADA Scan tab. 

When reviewing the report, we will focus on the issues flagged under the categories “Accessibility” and “Error” 

Many of the issues flagged under Accessibility are template related and can be ignored. We do want to address and resolve the content related issues flagged as failing the Accessibility Scan. These are some examples of flagged issues we want to resolve. For any issues flagged as Accessibility or Error and have the description in column F:


· iframe and frame elements must have a title attribute:  To fix, add title after iframe tag in the Source of the content “<iframe title="Campus Tour" src="campustourvideo.html"></iframe>


· Headings should not be empty:  To fix, find the empty heading in the Source with the line referenced in column E. 


· Identify row and column headers in data tables using th elements, and mark layout tables with role=presentation.


· This page contains some spelling errors: Review at the typo listed in Column G and update if needed. 

After this step is complete label the page status as “QA” in the Migration Tracker. 




Migration Status

Use the following status to track each page throughout the migration process.


· Manage - All steps under Manage Pages are complete. These include: recycling, moving and renaming the URL/page file. 

· Properties - All steps under Page Properties are complete. These include: updating page titles, meta description and navigation order.

· Format - All links, pdfs and images have been updated/fixed. Formatting issues for the page have been resolved. Page is mostly complete but may have a few outstanding issues. 

· QA - OU Campus page check tools have run. Final Sort Site Scan is complete. 

· Final - All QA issues have been resolved or flagged for site owners to address. 




Component Content: 

· Postcard
· Feature
· Highlight
· Hero

Read how to use components on OU Campus.

Snippet Content: 

· Cards 
· Calendar
· Media Object

Read how to use snippets on OU Campus.

Images:

When downloading images from the Photo Library select the option that is around 1200 px width. 

When uploading the image the CMS will also resize the image to fit the components, but we don't want to add files that are too large if not needed. Some pages in gather content may have the file attached -- but it may be larger than downloading a smaller file size from the library. 

Troubleshooting

The card component’s body copy needs to be wrapped in the card copy <p>:
[image: https://lh5.googleusercontent.com/UiF7qVdWGksexyrAlzXL-2-8_sRzml5IoX--kgjH0mLlS0n4RiD-bdrOM4mMJsFeF5u6e6-ZlGQuPMMn9n68zm3wzEY1tfhiHMuD83YOHjE7qjHwovMWSkEPPrOjZCS7BAT2ZtPD]
Currently, this tag can easily be removed by accident (a pending fix with OU). 

[image: https://lh3.googleusercontent.com/pxMUjnehRT-Q6iH_uMU29MMDeVpv1gPOhAaVbWKppqcmD-LwhbbH2z21Yg9J67xCvDQXr5hqD3JeHjraow_CS6OiffLz6ejVRVqXiOxWZbhRKdhSPvYMJvwP6rVNRxE0nll_mLQ-]

To fix you must:
1. Show blocks
2. Highlight body copy and select paragraph block
3. Select format to Card Component Text

Left: card with formatting issue - Right: Correct formatting

 [image: https://lh5.googleusercontent.com/AMju1f7Y8v0zFcQhT9EkcTVEbqFjTwrXiz8C6ZMv_surVmPvdKRtiMOevIHvyrlbfluddYfAtSLTPm3BUR3qnd0AYmsJvmZGsPR5LJCc81YUTD4VWjnrcDuSFXXH1aJnBkuqi7y8]
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Use SJISU Templates
and Toolkits

Need a specific template or
tool for a document or project?
We have SJSU-branded
letterhead, signage, Zoom
backgrounds and much more.

Download the Templates S
and Toolkits

Spartan Recreation and
Aguatic Center

The LEED Gold certified 128,000-
square-foot Spartan Recreation and
Aquatic Center demonstrates SJSU's
commitment to student health and
wellness.

Join SRAC >
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