
  Center for Faculty Development and Support 

Introduction to  
InDesign  

and  
Accessible PDF Export 

Tutorial 
 
 



Center for Faculty Development and Support 2 

Introduction to InDesign and Accessible PDF Export 

 
Objectives..................................................................................................................................................... 3 

A. Create Content ................................................................................................................................ 4 

1. Select A language ......................................................................................................................... 4 

2. Create a new document ................................................................................................................. 4 

3. Understand your pasteboard ......................................................................................................... 4 

4. Change the measurement unit ....................................................................................................... 4 

5. Create your grid system of margins and columns ......................................................................... 5 

6. Frequently used tools in the Toolbox ............................................................................................ 5 

7. Create Layers ................................................................................................................................ 6 

8. Create and manipulate text assets ................................................................................................. 6 

9. Flow text manually ....................................................................................................................... 6 

10. Create Styles ................................................................................................................................. 6 

11. Place and manipulate image assets ............................................................................................... 7 

12. Apply effects to assets of image or text ........................................................................................ 8 

13. Create background graphics or Master ......................................................................................... 8  

B. Tag Assets ........................................................................................................................................ 9 

14. Create and apply Tags ................................................................................................................... 9 

15. Add Alt text to tags of image assets.............................................................................................. 9 

16. Export to PDF ............................................................................................................................. 10 

C. Validate and Repair Accessibility ................................................................................................ 11 

17. Manual checks before Full Accessibility check .......................................................................... 11 

18. Run the Full Accessibility check ................................................................................................ 11 

19. Fix wrong tags............................................................................................................................. 11 

20. Add missing alternative text ....................................................................................................... 12 

21. Fix wrong tab (reading) order ..................................................................................................... 12 



Center for Faculty Development and Support 3 

 

Introduction to InDesign and Accessible PDF Export  

Objectives 
InDesign is a professional page-layout software that enables developers to create printed collaterals 
from flyers to publications. It also has the capability to export the collaterals as PDF files for 
repurposing on the Internet, such as dissemination for mobile devices, web sites, or simply as email 
attachments. PDF documents will contain all the layout formats as well as fonts from the InDesign 
source file. In addition, the Acrobat Reader, a free plug-in to read PDF documents from Adobe, also 
has a text-to-speech screen reader that reads the content.  

To achieve this goal of repurposing your InDesign digitally, your ultimate goal is to prepare an 
InDesign file is accessible that will also export as an accessible tagged PDF. Here are some major 
reminders on creating an accessible file effectively: 

1. In InDesign – create content 
a. Specify a language 
b. Create a Tag list corresponding to Acrobat Professional’s tagging convention 
c. Use Styles for formatting Character and Paragraph assets.  
d. Create content elements according to the reading order if possible. 
e. Avoid using outlined type or outlined drop caps or stick-up caps because they are images. 

2. In InDesign – tag content assets 
a. Tag content elements to create a content structure tree.  
b. Add Alt text to images. 

3. In Acrobat Professional – validate and repair accessibility 
a. Check language specification. 
b. Run screen reader Read Out Loud on the reading order and Alt text. 
c. Run Full Accessibility Check and repair according to the generated Accessibility Report. 

Phase1 
Create Content 

in  
InDesign 

Phase 2 
Tag Elements and 

Add Alt Text 
in  

InDesign 

Phase 3 
Check and 

Repair 
Accessibility in 

Acrobat  
Professional 
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A. Create Content 

1. Select A language 
1. After launching InDesign and BEFORE you create a 

new document, go to the Type menu and select 
Character. The Character panel appears on the right. 

2. In the Character panel navigate to the Language 
field. Select the appropriate language by opening the 
drop down menu of the Language field. 

2. Create a new document 
1. In the New Document window, select your 

document preferences such as number of 
pages, any facing spreads, folded size of 
your document, orientation, etc.  

2. By default, the preference for number of 
column is 1 and .5 in for margins. You can 
select the preferences for number of 
columns and margins measurement here, 
however you can change them later.  

3. Click OK when done. 

3. Understand your pasteboard 
1. Pasteboard is where you will place, create, and edit all your assets visible to printing. Here 

are some examples of documents in the Pasteboard.  

 

4. Change the measurement unit 
1. Go to the View menu and select Show Rulers. 
2.  Right click on the Rulers above your Pasteboard. The 

drop down menu appears. Select your preference.  
3. Do this step for BOTH of the horizontal and vertical 

rulers. The units change on the rulers accordingly. 
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5. Create your grid system of margins and columns 
1. Go to the Layout menu and select Margins and Column. The Margins and Columns window 

appears. 
2. Select the increments according to your layout requirements/sketch. 
3. Click the Chain icon if you want the top and bottom margins locked to the same increment. 

Select the number of columns in your grid. Select the Preview check box to preview results in 
Pasteboard. 

4. Note: If you are doing multiple pages with the same grid, you should prepare the margins and 
columns in a Master. You can find the Master in the Pages panel. Click and drag the 
appropriate Master to the corresponding Page to apply the elements of your Master. 

 

6. Frequently used tools in the Toolbox 
1. Notice the tools are in groups. Tool icons that have a black triangle at the lower right corners 

have more than one tool. Click and pause for a second to see the group of tools window appear. 
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7. Create Layers 
1. Go to the Window menu to find all your Panels. 

Each Panel will appear as a floating window. You 
can dock all the Panels on the right-hand side. 

2. Open the Layers panel.  
3. Create three layers: background; image; text 

8. Create and manipulate text assets 
1. Select the Type tool in the Toolbox to create a text frame. 
2. Click and drag a text frame with your cursor, align your text 

frame with your column if necessary. 
3. Input the headline or body text in the text frame.  
4. When you select the Type tool in the Toolbox, the 

Character/Paragraph Formatting Controls Panel appears on 
top of the pasteboard.  

 
5. To change the attributes of your text, highlight the text to be changed, go to the Controls 

Panel as shown in the above figure. You will find similar features between the Character 
Formatting Controls that is the top layer, and the Paragraph Formatting Controls 

that is the bottom layer. Activate the layers by clicking on the two icons of Character  
or Paragraph . 

9. Flow text manually 
1. For headline or quote 

a. If you see the red box with a plus sign appear at the end of 
your text frame that means you have hidden overflowing 
text. 

b. Click on the lower right or lower middle anchor point of the 
text frame and extend the frame to show all the text until the 
red box turns into a blue empty box. 

2. For Body copy 
a. If you are flowing text for body copy in a multi-column 

layout, you should click on the red box and load the hidden 
text to your cursor , and then click and unload to reflow 
the text in the next column. If you have created columns 
with the Margins and Columns feature, the reflowed text 
will fill up the next column automatically. 
 

10. Create Styles for text 
1. Open the Character Styles panel under Types and Tables. The Character and Paragraph 

Styles window appears.  
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2. Click on the Create New Style icon to set your font attributes. The Character Style 

Options window appears. To start, select the layer of Basic Character Formats to enter your 
preferences for font attributes. Click OK when done with defining your options. 

   
3. To apply the Style, first highlight your text in the pasteboard then select your preferred Style 

in the Character/Paragraph panel.  Change of the Style appears in your text frame. 

11. Place and manipulate image assets 
1. Select the Image layer in the Layer panel under the Window menu. 
2. Go to the File menu and select Place. The file directory window appears. Locate your image 

file and click Open.  

3. Your cursor will change to a paint brush  indicating it has been loaded with your selected 
image. Click to place your image in your pasteboard. Your image appears in full size. 

 
 

4. If you need to fit a certain part of the image to a pre-determined content frame size that is 
smaller than your image, first create the content frame with the Frame tool  in the Toolbox. 
Place the image.  
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5. Use the Directional Selection Tool  in the Toolbox to select the entire image that might 
extend beyond the blue content frame. Your selected image appears in the brown outlined 
image frame but only the part appears within the blue outlined content frame will be visible 
therefore you need to drag the image around to determine your visible area of the image. 

  
6. To scale the size of image: First select the blue content frame with the image with your 

Selection Tool . Then select the Scale tool  in the Toolbox and click on the image to 
resize.  

7. You can also use the Free Transform   tool to resize or rotate your assets. Press the Shift 
key at the same time if the resizing needs to be proportional with this tool.  

12. Apply effects to assets of image or text 
1. Select the frame of your asset, such as the text frame of your headline.  
2. Right click on the frame and the Options menu appears. Navigate to Effects.. and select from 

the list of options in Effects. The Effects window appears and you can access all effects here. 

 

13. Create background graphics or Master 
1. Select the Background layer. 
2. Place the logo lockup PS file from PA. 
3. Position it according to your layout. Resize if necessary with the Scale tool from the Toolbox.  
4. NOTE: If you have more than one page that requires the logo, or any other assets, to appear 

consistently in the pages, you should create a new Master in the Pages panel for these assets.  
5. To create the Master, right click on the None Master icon and select New Master in the 

pop-up options window.  
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6. Name your Master with Prefix and Name, such as L for prefix and Logo Master for the name. 
A new pasteboard for the Master appears with the same 
dimension as your page. 

7. Place the logo, or any assets in this pasteboard. You have 
to apply your Master to the desired page in order to make 
the content visible in printing. 

8. To apply the Master, drag the icon of your new Master 
and drop it over your desired page in the Page section of 
your panel. The Master’s content will appear in your 
selected page. Repeat this drag and drop step for the 
pages that need this Master. 

B. Tag Assets 

14. Create and apply Tags 
1. In order to export your document successfully in an accessible 

format you will need to create a structure tree for your content.  
2. Go to the Window menu and select Tags. The Tags panel 

appears. 
3. Select New Tag from the Tags panel.  
4. Click on the New Tag icon and enter a name for that tag. Use 

lower cases and no more than one word. 
5. Click on the color swatch on the left to select a color for this 

tag.  
6. To apply a tag, drag and drop the tag to your asset and the 

frame of the asset will assume a tint of the same tag color. 
For example drag and drop the dark blue heading1 tag to your text frame of your headline, the 
background of your text frame will have a tint of dark blue.  

7. Make sure all assets are tagged.  
8. NOTE: If you want to create a tag list for PDF exporting purpose, then you would want to 

create tags with the same names as they are in Acrobat Professional.  

15. Add Alt text to tags of image assets 
1. In order to export successfully as an accessible document you need to add descriptions to your 

image assets because this will benefit readers using a text-to-speech software, a screen reader, 
to understand your content since images are not text.  

2. Make sure you already have tagged all your assets, especially the image assets. 
3. Go to the View menu and navigate to Structure and select Show structure if not already 

selected. 
4. In the Structure window all the tagged items that you created earlier appear in an ordered list. 

Select and right click on the figure tag of your 
asset and select New attribute… The New 
Attribute window appears. 

5. In the New Attribute window enter Alt for 
name (case sensitive) and provide a text 
equivalent description of your image in the 
Value text box. Click OK when done. 
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6. The Alt text appears below your figure tag. 

 

16. Export to PDF 
1. Save document.  
2. Go to the File menu and select Export.  
3. In the Export PDF window, check the selection of Create Tagged PDF. If you prefer your 

facing pages appear as one page (spread) you would want to select Spreads. 
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C. Validate and Repair Accessibility 

17. Manual checks before Full Accessibility check 
1. Running these checks manually will expedite your Full Accessibility check later. 
2. Language 

a. Go to the File menu and select Properties or Document Properties. The Properties 
window appears. 

b. Select the Advanced tab and navigate to the bottom Reading Options and select English, 
or other preferred language as your language specification in the pop down menu. 

3. Tags 
a. Go to the Advanced menu and navigate to Accessibility and select Add Tags to 

Document if it is highlighted.  
4. Alt text 

a. Move your cursor over an image to check if the Alt text that you entered is popping up in 
a tooltip like text box above the image. 

18. Run the Full Accessibility check 
1. Go to the Advanced menu and navigate to Accessibility and select Full check. The 

Accessibility Full Check window appears. 
2. In the Checking Options select Adobe PDF as the name and select all the check boxes for 

general requirements and click the Start Checking button.  
3. If Adobe Acrobat found any possible problems, a message dialog box would appear to ask you 

to view a report. Click OK. The Accessibility Report appears on your left. (If you pass the 
Accessibility check, a message of congratulations will appear.) 

4. In the Accessibility Report you are likely to encounter the following kinds of problem solving. 
5. IMPORTANT: There is no Undo or Save in this the Touchup Reading Order process. 

Remember to close the Touchup Reading Order window and save your steps.  

19. Fix wrong tags 
1. Sometimes assets are wrongly tagged 

or recognized (during the conversion 
from InDesign to Acrobat) such as a 
figure recognized as text, or vice versa, 
etc. 

2. Go to the Advanced menu and 
navigate to Accessibility. 

3. Select the Touchup Reading Order 
option. The Touchup Reading Order 
window appears on the left.  

4. Click and drag a blue rectangle with 
your cross-hair cursor to select the 
object/s with the wrong Tag. The Tag 
buttons in the Touchup Reading 
Order window become active. 

5. Click on an appropriate Tag button 
and the Tag of the selected object/s will change accordingly.  

 

Tab number Tag button 
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6. If you do not want an object to be recognized, you can select the Background tag for that 
object. As a result the object will no longer be highlighted.  

7. Close the Touchup Reading Order window and save. Run the Accessibility Full Check 
again. 

20. Add missing alternative text 
1. Examples for this problem could be multiple: an image in your document did not have 

alternative text embedded in the authoring application or certain text assets were mistakenly 
recognized as a figure/image during the conversion process.  

2. Go to the Advanced menu and navigate to Accessibility. Select the Touchup Reading Order 
option in the options list. The Touchup Reading Order window appears on the left. Elements 
of your documents appear highlighted with tags and reading order number.  

3. If you see a figure tag says “Figure – No alternate text exists.” right click on the Figure 
object and select Edit Alternative Text…Enter the description in the text box and click OK. 

8. Close the Touchup Reading Order window and save. Run the Accessibility Full Check 
again. 

21.  Fix wrong tab (reading) order 
1. Go to the View menu and navigate to Navigation Panels and select Order in the expanded 

list. The floating Order panel appears. 
2. In the Order panel, click on the Plus sign next to a label to collapse the list of reading order. 

The Plus sign now is a Minus sign. 
3. Click and drag the Box icon up or down to correct the reading order. While dragging, you will 

see a black arrow followed by a horizontal line adhered to your cursor, indicating a possible 
location for insertion. Release and drop your dragged icon at that location. The reading order 
number of that object will change accordingly.  

4. Close the Touchup Reading Order window and save. Run the Accessibility Full Check 
again. 
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